Remove masked for removal package
[gentoo.git] / app-laptop / i8kutils / i8kutils-1.42.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils systemd toolchain-funcs
7
8 DESCRIPTION="Dell Inspiron and Latitude utilities"
9 HOMEPAGE="https://launchpad.net/i8kutils"
10 SRC_URI="https://launchpad.net/i8kutils/trunk/${PV}/+download/${P/-/_}.tar.xz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="tk"
16
17 DEPEND="tk? ( dev-lang/tk:0 )"
18 RDEPEND="${DEPEND}
19         sys-power/acpi"
20
21 S="${WORKDIR}/${PN}"
22
23 DOCS=( README.i8kutils )
24
25 src_prepare() {
26         epatch "${FILESDIR}/${PN}-gcc5.patch"
27         epatch "${FILESDIR}/${P}-Makefile.patch"
28
29         tc-export CC
30 }
31
32 src_install() {
33         dobin i8kctl i8kfan
34         doman i8kctl.1
35         dodoc README.i8kutils
36
37         newinitd "${FILESDIR}"/i8k.init-r1 i8k
38         newconfd "${FILESDIR}"/i8k.conf i8k
39
40         if use tk; then
41                 dobin i8kmon
42                 doman i8kmon.1
43                 dodoc i8kmon.conf
44                 systemd_dounit "${FILESDIR}"/i8kmon.service
45         else
46                 cat >> "${ED}"/etc/conf.d/i8k <<- EOF
47
48                 # i8kmon disabled because the package was installed without USE=tk
49                 NOMON=1
50                 EOF
51         fi
52 }