app-i18n/skk-jisyo: new snapshot
[gentoo.git] / app-i18n / translate-shell / translate-shell-0.9.6.10.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Online command-line translator"
7 HOMEPAGE="https://www.soimort.org/translate-shell/"
8 SRC_URI="https://github.com/soimort/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="Unlicense"
11 SLOT="0"
12 KEYWORDS="~amd64"
13 IUSE="+bidi +curl test tts"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="
17         app-misc/rlwrap
18         =sys-apps/gawk-4*
19         curl? ( net-misc/curl[ssl] )
20         bidi? ( dev-libs/fribidi )
21         tts? ( || (
22                 media-sound/mpg123
23                 app-accessibility/espeak
24                 media-video/mpv
25                 media-video/mplayer
26                 )
27         )"
28 DEPEND="${RDEPEND}
29         test? ( >=app-editors/emacs-23.1:* )
30         "
31
32 src_test() {
33         emake NETWORK_ACCESS=no test
34 }
35
36 src_install() {
37         emake PREFIX="${D}/usr" install
38 }