sci-mathematics/rstudio: Thanks to tomboy-64 for fixing bug Bug 534152 - sci-mathemat...
[gentoo.git] / app-i18n / scim-anthy / scim-anthy-1.3.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="2"
6
7 inherit libtool
8
9 DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
10 HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
11 SRC_URI="mirror://sourceforge.jp/scim-imengine/29660/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
16 IUSE="gtk nls"
17
18 DEPEND=">=app-i18n/scim-1.2[-gtk3]
19         || ( >=app-i18n/anthy-7500 >=app-i18n/anthy-ss-7500 )
20         nls? ( virtual/libintl )
21         gtk? ( >=x11-libs/gtk+-2.8:2 )"
22 RDEPEND="${DEPEND}
23         gtk? ( app-dicts/kasumi )"
24 DEPEND="${DEPEND}
25         nls? ( sys-devel/gettext )
26         virtual/pkgconfig"
27
28 src_prepare() {
29         elibtoolize
30 }
31
32 src_configure() {
33         econf \
34                 $(use_enable nls) \
35                 --disable-static \
36                 --disable-dependency-tracking || die
37 }
38
39 src_compile() {
40         emake || die "emake failed"
41 }
42
43 src_install() {
44         emake DESTDIR="${D}" install || die "emake install failed"
45         dodoc AUTHORS ChangeLog NEWS README
46 }
47
48 pkg_postinst() {
49         elog
50         elog "To use SCIM, you should use the following in your user startup scripts"
51         elog "such as .gnomerc or .xinitrc:"
52         elog
53         elog "LANG='your_language' scim -d"
54         elog "export XMODIFIERS=@im=SCIM"
55         elog "export GTK_IM_MODULE=scim"
56         elog "export QT_IM_MODULE=scim"
57         elog
58 }