sci-mathematics/rstudio: Thanks to tomboy-64 for fixing bug Bug 534152 - sci-mathemat...
[gentoo.git] / app-i18n / scim-anthy / scim-anthy-1.2.7-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils
8
9 DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
10 HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
11 SRC_URI="mirror://sourceforge.jp/scim-imengine/37309/${P}.tar.gz
12         gtk3?   ( https://dev.gentoo.org/~heroxbd/${P}-patches.tar.xz )"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="alpha amd64 ~arm ppc sparc x86 ~x86-fbsd"
17 IUSE="+gtk3 nls kasumi"
18
19 DEPEND=">=app-i18n/scim-1.2[gtk3=]
20         >=app-i18n/anthy-5900
21         nls? ( virtual/libintl )
22         gtk3? ( x11-libs/gtk+:3 )"
23 RDEPEND="${DEPEND}
24         kasumi? ( app-dicts/kasumi )"
25 DEPEND="${DEPEND}
26         nls? ( sys-devel/gettext )
27         virtual/pkgconfig"
28
29 src_prepare() {
30         if use gtk3; then
31                 EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" epatch
32         fi
33
34         eautoreconf
35 }
36
37 src_configure() {
38         econf \
39                 $(use_enable nls) \
40                 --disable-static \
41                 --disable-dependency-tracking
42 }
43
44 src_install() {
45         default
46         dodoc AUTHORS ChangeLog NEWS README
47 }