app-i18n: Remove *-fbsd KEYWORDS
[gentoo.git] / app-i18n / scim-anthy / scim-anthy-1.2.7-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools eutils
7
8 DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
9 HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
10 SRC_URI="mirror://sourceforge.jp/scim-imengine/37309/${P}.tar.gz
11         gtk3?   ( https://dev.gentoo.org/~heroxbd/${P}-patches.tar.xz )"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 ~arm ppc sparc x86"
16 IUSE="+gtk3 nls kasumi"
17
18 DEPEND=">=app-i18n/scim-1.2[gtk3=]
19         >=app-i18n/anthy-5900
20         nls? ( virtual/libintl )
21         gtk3? ( x11-libs/gtk+:3 )"
22 RDEPEND="${DEPEND}
23         kasumi? ( app-dicts/kasumi )"
24 DEPEND="${DEPEND}
25         nls? ( sys-devel/gettext )
26         virtual/pkgconfig"
27
28 src_prepare() {
29         default
30
31         if use gtk3; then
32                 EPATCH_SOURCE="${WORKDIR}/patches" EPATCH_SUFFIX="patch" epatch
33         else
34                 epatch "${FILESDIR}/${P}-gtk2_build.patch"
35         fi
36
37         eautoreconf
38 }
39
40 src_configure() {
41         econf \
42                 $(use_enable nls) \
43                 --disable-static \
44                 --disable-dependency-tracking
45 }
46
47 src_install() {
48         default
49         dodoc AUTHORS ChangeLog NEWS README
50 }