dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-i18n / kcm-fcitx / kcm-fcitx-4.5.9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit cmake-utils
7
8 if [[ "${PV}" =~ (^|\.)9999$ ]]; then
9         inherit git-r3
10
11         EGIT_REPO_URI="https://gitlab.com/fcitx/kcm-fcitx.git"
12 fi
13
14 DESCRIPTION="KDE configuration module for Fcitx"
15 HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/kcm-fcitx"
16 if [[ "${PV}" =~ (^|\.)9999$ ]]; then
17         SRC_URI=""
18 else
19         SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
20 fi
21
22 LICENSE="GPL-2+"
23 SLOT="4-plasma5"
24 KEYWORDS=""
25 IUSE=""
26
27 RDEPEND=">=app-i18n/fcitx-4.2.9:4
28         >=app-i18n/fcitx-qt5-1.1:4
29         dev-qt/qtcore:5
30         dev-qt/qtdbus:5
31         dev-qt/qtgui:5
32         dev-qt/qtwidgets:5
33         dev-qt/qtx11extras:5
34         kde-frameworks/kconfigwidgets:5
35         kde-frameworks/kcoreaddons:5
36         kde-frameworks/ki18n:5
37         kde-frameworks/kio:5
38         kde-frameworks/kitemviews:5
39         kde-frameworks/knewstuff:5
40         kde-frameworks/kwidgetsaddons:5
41         virtual/libintl
42         x11-libs/libX11
43         x11-libs/libxkbfile
44         !${CATEGORY}/${PN}:4[-minimal(-)]"
45 DEPEND="${RDEPEND}
46         kde-frameworks/extra-cmake-modules:5
47         sys-devel/gettext
48         virtual/pkgconfig"
49
50 src_configure() {
51         local mycmakeargs=(
52                 -DKDE_INSTALL_USE_QT_SYS_PATHS=yes
53         )
54
55         cmake-utils_src_configure
56 }