Use https by default
[gentoo.git] / app-i18n / ibus-sunpinyin / ibus-sunpinyin-2.0.4_pre20130108-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_DEPEND="2:2.5"
7 inherit python scons-utils toolchain-funcs
8
9 DESCRIPTION="The SunPinYin IMEngine for IBus Framework"
10 HOMEPAGE="https://sunpinyin.googlecode.com/"
11 SRC_URI="https://dev.gentoo.org/~yngwin/distfiles/sunpinyin-${PV}.tar.xz"
12
13 LICENSE="LGPL-2.1 CDDL"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="+nls"
17
18 RDEPEND="app-i18n/ibus
19         ~app-i18n/sunpinyin-${PV}:=
20         nls? ( virtual/libintl )"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23         nls? ( sys-devel/gettext )"
24
25 src_unpack() {
26         default
27         mv "${WORKDIR}/sunpinyin-${PV}" "${S}" || die
28 }
29
30 src_configure() {
31         tc-export CXX
32         myesconsargs=(
33                 --prefix="${EPREFIX}"/usr
34                 --libexecdir="${EPREFIX}"/usr/libexec
35         )
36 }
37
38 src_compile() {
39         pushd "${S}"/wrapper/ibus
40         escons
41         popd
42 }
43
44 src_install() {
45         pushd "${S}"/wrapper/ibus
46         escons --install-sandbox="${ED}" install
47         popd
48 }
49
50 pkg_postinst() {
51         python_mod_optimize /usr/share/ibus-sunpinyin/setup
52 }
53
54 pkg_postrm() {
55         python_mod_cleanup /usr/share/ibus-sunpinyin/setup
56 }