Convert URIs for googlecode.com to https
[gentoo.git] / app-i18n / ibus-handwrite / ibus-handwrite-2.1.4-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8 inherit eutils python-single-r1 autotools-utils multilib
9
10 DESCRIPTION="hand write recognition/input using ibus IM engine"
11 HOMEPAGE="https://code.google.com/p/ibus-handwrite/"
12 SRC_URI="https://ibus-handwrite.googlecode.com/files/${P}.tar.bz2"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="nls +zinnia"
18
19 RDEPEND="zinnia? ( app-i18n/zinnia app-i18n/zinnia-tomoe )
20         >=app-i18n/ibus-1.3.0
21         >=x11-libs/gtk+-2.10
22         x11-libs/gtkglext"
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig"
25
26 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
27
28 DOCS=( AUTHORS ChangeLog NEWS README )
29
30 src_prepare() {
31         epatch "${FILESDIR}"/${PN}-link.patch #bug #501954
32 }
33
34 src_configure() {
35         local myeconfargs=(
36                 $(use_enable nls)
37                 $(use_enable zinnia)
38                 $(use_with zinnia zinnia-tomoe "${EPREFIX}"/usr/$(get_libdir)/zinnia/model/tomoe)
39         )
40         autotools-utils_src_configure
41 }