net-misc/dhcpcd: amd64 stable wrt bug #718916
[gentoo.git] / app-i18n / fcitx-sunpinyin / fcitx-sunpinyin-4.9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit cmake-utils gnome2-utils
7
8 if [[ "${PV}" =~ (^|\.)9999$ ]]; then
9         inherit git-r3
10
11         EGIT_REPO_URI="https://gitlab.com/fcitx/fcitx-sunpinyin.git"
12 fi
13
14 DESCRIPTION="Chinese SunPinyin input method for Fcitx"
15 HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/fcitx-sunpinyin"
16 if [[ "${PV}" =~ (^|\.)9999$ ]]; then
17         SRC_URI=""
18 else
19         SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
20 fi
21
22 LICENSE="GPL-2+"
23 SLOT="4"
24 KEYWORDS=""
25 IUSE=""
26
27 RDEPEND=">=app-i18n/fcitx-4.2.9:4
28         >=app-i18n/sunpinyin-2.0.4_alpha:=
29         virtual/libintl"
30 DEPEND="${RDEPEND}
31         virtual/pkgconfig"
32
33 DOCS=(AUTHORS)
34
35 pkg_postinst() {
36         gnome2_icon_cache_update
37 }
38
39 pkg_postrm() {
40         gnome2_icon_cache_update
41 }