dev-haskell/vector-th-unbox: bump up to 0.2.1.3
[gentoo.git] / app-i18n / fcitx-rime / fcitx-rime-0.2.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit cmake-utils
8
9 DESCRIPTION="Rime support for Fcitx"
10 HOMEPAGE="http://fcitx-im.org/"
11 SRC_URI="https://fcitx.googlecode.com/files/${P}.tar.xz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ~ppc ~ppc64 x86"
16 IUSE=""
17
18 RDEPEND=">=app-i18n/fcitx-4.2.7
19         app-i18n/librime
20         app-i18n/rime-data
21         x11-libs/libnotify"
22 DEPEND="${RDEPEND}"
23
24 src_prepare() {
25         # dont build data resource here, already provided by app-i18n/rime-data
26         sed -i -e 's|add_subdirectory(data)||' CMakeLists.txt || die
27 }
28
29 src_configure() {
30         local mycmakeargs=(
31                 -DRIME_DATA_DIR=/usr/share/rime-data
32         )
33         cmake-utils_src_configure
34 }