Drop $Id$ per council decision in bug #611234.
[gentoo.git] / app-forensics / zzuf / zzuf-0.13-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit autotools eutils
7
8 DESCRIPTION="Transparent application input fuzzer"
9 HOMEPAGE="http://caca.zoy.org/wiki/zzuf"
10 SRC_URI="http://caca.zoy.org/files/${PN}/${P}.tar.gz
11         https://dev.gentoo.org/~cardoe/distfiles/${P}-zzcat-zzat-rename.patch.bz2"
12
13 LICENSE="WTFPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~sparc ~x86"
16 IUSE=""
17
18 # fails with sandbox enabled
19 RESTRICT="test"
20
21 DOCS=( AUTHORS ChangeLog NEWS README TODO )
22
23 src_prepare() {
24         sed -i -e '/CFLAGS/d' "${S}"/configure.ac \
25                 || die "unable to fix the configure.ac"
26         sed -i -e 's:noinst_:check_:' "${S}"/test/Makefile.am \
27                 || die "unable to fix unconditional test building"
28
29         epatch "${DISTDIR}"/${P}-zzcat-zzat-rename.patch.bz2
30
31         eautoreconf
32 }
33
34 src_configure() {
35         # Don't build the static library, as the library is only used for
36         # preloading, so there is no reason to build it statically, unless
37         # you want to use zzuf with a static-linked executable, which I'm
38         # not even sure would be a good idea.
39         econf --disable-static
40 }
41
42 src_install() {
43         default
44
45         find "${D}" -name '*.la' -delete
46 }