dev-qt/qtopengl: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-forensics / volatility / volatility-2.6-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 )
7 inherit distutils-r1
8
9 DESCRIPTION="Framework for analyzing volatile memory"
10 HOMEPAGE="https://www.volatilityfoundation.org/"
11 SRC_URI="https://downloads.volatilityfoundation.org/releases/${PV}/${P}.zip"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 S=${WORKDIR}/${PN}-master
19
20 DEPEND="app-arch/unzip"
21 RDEPEND=">=dev-libs/distorm64-3[${PYTHON_USEDEP}]
22         dev-libs/libpcre
23         || (
24                 dev-python/pycryptodome[${PYTHON_USEDEP}]
25                 dev-python/pycrypto[${PYTHON_USEDEP}]
26         )"
27
28 src_install() {
29         distutils-r1_src_install
30         mkdir "${D}/usr/share/${PN}" || die
31         mv "${D}/usr/contrib/plugins" "${D}/usr/share/${PN}/" || die
32         rmdir --ignore-fail-on-non-empty "${D}/usr/contrib" || die
33         mv "${D}/usr/tools" "${D}/usr/share/${PN}/" || die
34         dosym vol.py /usr/bin/volatility
35 }