*/*: Bump copyright on files touched this year
[gentoo.git] / app-forensics / radamsa / radamsa-0.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs vcs-snapshot
7
8 DESCRIPTION="A general purpose fuzzer"
9 HOMEPAGE="https://gitlab.com/akihe/radamsa"
10 SRC_URI="
11         https://gitlab.com/akihe/radamsa/-/archive/v${PV}/${P}.tar.gz
12         https://gitlab.com/akihe/radamsa/uploads/a2228910d0d3c68d19c09cee3943d7e5/${P}.c.gz
13 "
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RESTRICT=test # needs an owl-lisp
21
22 DOCS=( LICENCE NEWS README.md )
23
24 src_prepare() {
25         default
26
27         cp ../${P}.c ./radamsa.c || die
28 }
29
30 src_compile() {
31         emake bin/radamsa CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
32 }
33
34 src_install() {
35         dobin bin/radamsa
36         # avoid man compression by build system
37         doman doc/radamsa.1
38
39         einstalldocs
40 }