app-forensics/memdump: ppc stable wrt bug #683882
[gentoo.git] / app-forensics / examiner / examiner-0.5-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Utilizes the objdump command to disassemble and comment foreign binaries"
7 HOMEPAGE="http://www.academicunderground.org/examiner/"
8 SRC_URI="http://www.academicunderground.org/examiner/${P}.tar.gz"
9
10 LICENSE="GPL-2+"
11 SLOT="0"
12 KEYWORDS="~amd64 ~ppc ~x86"
13
14 RDEPEND="dev-lang/perl"
15
16 src_prepare() {
17         default
18         # Do not install docs through Makefile wrt bug #241256
19         sed -i -e '/$(DOC)/d' Makefile || die 'sed failed'
20         eapply "${FILESDIR}"/${P}-perl.patch
21 }
22
23 src_compile() { :; }
24
25 src_install() {
26         dodir /usr/bin /usr/share/${PN} /usr/share/man/man1
27
28         emake \
29                 MAN="${D}/usr/share/man/man1" \
30                 BIN="${D}/usr/bin" \
31                 SHARE="${D}/usr/share/examiner" \
32                 install
33
34         dodoc docs/{README*,BUGS,CHANGELOG,TODO,TUTORIAL}
35         dodoc -r utils
36 }