Merge github#931: dev-perl/MongoDB: version bump to v1.2.2
[gentoo.git] / app-eselect / eselect-python / eselect-python-99999999.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 if [[ ${PV} == "99999999" ]] ; then
8         inherit autotools git-r3
9         EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
10 else
11         SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
12         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
13 fi
14
15 DESCRIPTION="Eselect module for management of multiple Python versions"
16 HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
17
18 LICENSE="GPL-2"
19 SLOT="0"
20 IUSE=""
21
22 # python-exec-2.4.2 for working -l option
23 RDEPEND=">=app-admin/eselect-1.2.3
24         >=dev-lang/python-exec-2.4.2"
25
26 src_prepare() {
27         [[ ${PV} == "99999999" ]] && eautoreconf
28 }
29
30 pkg_postinst() {
31         local py
32
33         if has_version 'dev-lang/python'; then
34                 eselect python update --if-unset
35         fi
36
37         if has_version "=dev-lang/python-3*"; then
38                 eselect python update "--python3" --if-unset
39         fi
40 }