7c58bdeb2d8d699c30900eccc07af7eee964303f
[gentoo.git] / app-eselect / eselect-python / eselect-python-20171204.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ ${PV} == "99999999" ]] ; then
7         inherit autotools git-r3
8         EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
9 else
10         SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
11         KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
12 fi
13
14 DESCRIPTION="Eselect module for management of multiple Python versions"
15 HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Python"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 IUSE=""
20
21 # python-exec-2.4.2 for working -l option
22 RDEPEND=">=app-admin/eselect-1.2.3
23         >=dev-lang/python-exec-2.4.2"
24
25 src_prepare() {
26         default
27         [[ ${PV} == "99999999" ]] && eautoreconf
28 }
29
30 pkg_postinst() {
31         local py
32
33         if has_version 'dev-lang/python'; then
34                 eselect python update --if-unset
35         fi
36
37         if has_version "=dev-lang/python-3*"; then
38                 eselect python update "--python3" --if-unset
39         fi
40 }