app-eselect/eselect-python: x86 stable wrt bug #575948
[gentoo.git] / app-eselect / eselect-python / eselect-python-20140125-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils
8
9 if [[ ${PV} == "99999999" ]] ; then
10         inherit autotools git-r3
11         EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git"
12 else
13         SRC_URI="mirror://gentoo/${P}.tar.bz2
14                 https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
15         KEYWORDS="alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
16 fi
17
18 DESCRIPTION="Eselect module for management of multiple Python versions"
19 HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
20
21 LICENSE="GPL-2"
22 SLOT="0"
23 IUSE=""
24
25 RDEPEND=">=app-admin/eselect-1.2.3"
26
27 src_prepare() {
28         epatch "${FILESDIR}"/${P}-pythonX.Y-config.patch
29         [[ ${PV} == "99999999" ]] && eautoreconf
30 }
31
32 src_install() {
33         keepdir /etc/env.d/python
34         emake DESTDIR="${D}" install
35 }
36
37 pkg_postinst() {
38         if has_version 'dev-lang/python'; then
39                 eselect python update --if-unset
40         fi
41         if has_version '=dev-lang/python-2*'; then
42                 eselect python update --python2 --if-unset
43         fi
44         if has_version '=dev-lang/python-3*'; then
45                 eselect python update --python3 --if-unset
46         fi
47 }