app-eselect/eselect-postgresql-2.4-r0: alpha stable
[gentoo.git] / app-eselect / eselect-postgresql / eselect-postgresql-2.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Utility to select the default PostgreSQL slot"
7 HOMEPAGE="https://www.gentoo.org/"
8 SRC_URI="https://dev.gentoo.org/~titanofold/${P}.tbz2"
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
12
13 RDEPEND="app-admin/eselect"
14
15 # All dev-db/postgresql ebuilds from 10.0 on are well supported. Earlier
16 # ebuilds may present some quality of life issues.
17 PDEPEND="
18         !<dev-db/postgresql-9.6.2-r1:9.6
19         !<dev-db/postgresql-9.5.6-r1:9.5
20         !<dev-db/postgresql-9.4.11-r1:9.4
21         !<dev-db/postgresql-9.3.16-r1:9.3
22         !<dev-db/postgresql-9.2.20-r1
23 "
24
25 src_install() {
26         insinto /usr/share/eselect/modules
27         doins postgresql.eselect
28
29         dosym eselect /usr/bin/postgresql-config
30 }
31
32 pkg_postinst() {
33         postgresql-config update
34 }