dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-eselect / eselect-php / eselect-php-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit git-r3 autotools
7
8 DESCRIPTION="PHP eselect module"
9 HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
10 EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/eselect-php.git"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="fpm apache2"
16
17 # The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
18 RDEPEND="app-admin/eselect
19         apache2? ( www-servers/apache[apache2_modules_dir] )"
20
21 src_prepare() {
22         default
23         eautoreconf
24 }
25
26 src_configure() {
27         # We expect localstatedir to be "var"ish, not "var/lib"ish, because
28         # that's what PHP upstream expects. See for example the FPM
29         # configuration where they put logs in @localstatedir@/log.
30         #
31         # The libdir is passed explicitly in case the /usr/lib symlink
32         # is not present (bug 624528).
33         econf --libdir="${EPREFIX}/usr/$(get_libdir)" \
34                   --localstatedir="${EPREFIX}/var" \
35                   --with-piddir="${EPREFIX}/run" \
36                   $(use_enable apache2) \
37                   $(use_enable fpm)
38 }