Use https by default
[gentoo.git] / app-eselect / eselect-php / eselect-php-0.7.1-r4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit depend.apache systemd
8
9 DESCRIPTION="PHP eselect module"
10 HOMEPAGE="https://www.gentoo.org"
11 SRC_URI="https://dev.gentoo.org/~olemarkus/eselect-php/eselect-php-${PV}.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
16 IUSE="fpm apache2"
17
18 DEPEND=">=app-admin/eselect-1.2.4
19                 !<dev-lang/php-5.3.23-r1:5.3
20                 !<dev-lang/php-5.4.13-r1:5.4
21                 !<dev-lang/php-5.5.0_beta1-r2:5.5
22                 "
23 RDEPEND="${DEPEND}"
24
25 S="${WORKDIR}"
26
27 want_apache
28
29 src_install() {
30         mv eselect-php-${PV} php.eselect
31         insinto /usr/share/eselect/modules/
32         doins php.eselect
33
34         if use apache2 ; then
35                 insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
36                 newins "${FILESDIR}/70_mod_php5.conf-apache2-r1" \
37                         "70_mod_php5.conf"
38         fi
39
40         if use fpm ; then
41                 dodir "/etc/init.d"
42                 insinto "/etc/init.d"
43                 newinitd "${FILESDIR}/php-fpm-r1.init" "php-fpm"
44                 systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
45                 exeinto /usr/libexec
46                 doexe "${FILESDIR}/php-fpm-launcher"
47         fi
48 }