Merge remote-tracking branch 'github/pr/372'.
[gentoo.git] / app-eselect / eselect-lcdfilter / eselect-lcdfilter-2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit vcs-snapshot readme.gentoo
7
8 DESCRIPTION="Eselect module to choose Freetype infinality-enhanced LCD filtering settings"
9 HOMEPAGE="https://github.com/yngwin/eselect-lcdfilter"
10 SRC_URI="${HOMEPAGE}/tarball/v${PV} -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND="app-admin/eselect"
19 PDEPEND="media-libs/freetype[infinality]"
20
21 src_install() {
22         DOC_CONTENTS="Use eselect lcdfilter to select an lcdfiltering font style.
23         You can customize ${EPREFIX}/usr/share/${PN}/env.d/custom with your own settings.
24         See ${EPREFIX}/usr/share/doc/${PF}/infinality-settings.sh for an explanation and
25         examples of the variables. This module is supposed to be used in pair with
26         eselect infinality."
27
28         dodoc README.rst infinality-settings.sh
29         readme.gentoo_create_doc
30
31         insinto "/usr/share/eselect/modules"
32         doins lcdfilter.eselect
33
34         insinto "/usr/share/${PN}"
35         doins -r env.d
36 }