app-eselect/eselect-lcdfilter: drop old EAPI
[gentoo.git] / app-eselect / eselect-lcdfilter / eselect-lcdfilter-2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit vcs-snapshot readme.gentoo-r1
6
7 DESCRIPTION="Eselect module to choose Freetype infinality-enhanced LCD filtering settings"
8 HOMEPAGE="https://github.com/yngwin/eselect-lcdfilter"
9 SRC_URI="https://github.com/yngwin/eselect-lcdfilter/tarball/v${PV} -> ${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE=""
15
16 RDEPEND="app-admin/eselect"
17 PDEPEND="media-libs/freetype[infinality]"
18
19 DOC_CONTENTS="Use eselect lcdfilter to select an lcdfiltering font style.
20         You can customize ${EPREFIX}/usr/share/"${PN}"/env.d/custom with your own settings.
21         See ${EPREFIX}/usr/share/doc/"${PF}"/infinality-settings.sh for an explanation and
22         examples of the variables. This module is supposed to be used in pair with
23         eselect infinality."
24
25 src_install() {
26         dodoc README.rst infinality-settings.sh
27         readme.gentoo_create_doc
28
29         insinto "/usr/share/eselect/modules"
30         doins lcdfilter.eselect
31
32         insinto "/usr/share/${PN}"
33         doins -r env.d
34 }