www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / app-emulation / x48 / x48-0.6.4-r2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="HP48 Calculator Emulator"
9 HOMEPAGE="http://x48.berlios.de/"
10 SRC_URI="mirror://sourceforge/x48.berlios/${P}.tar.bz2"
11 LICENSE="GPL-3"
12
13 SLOT="0"
14 KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86"
15 IUSE="readline"
16
17 RDEPEND="
18         x11-libs/libX11
19         x11-libs/libXext
20         readline? ( sys-libs/readline:0= )"
21 DEPEND="${RDEPEND}
22         virtual/pkgconfig
23         x11-libs/libXt"
24
25 src_unpack() {
26         mkdir -p "${S}"
27         cd "${S}"
28         unpack ${A}
29 }
30
31 src_prepare() {
32         default
33         sed -i '698s/inline/static inline/' src/emulate.c || die
34         eautoreconf
35 }
36
37 src_configure() {
38         econf $(use_enable readline)
39 }
40
41 src_install() {
42         default
43
44         insinto /usr/share/"${PN}"/romdump
45         doins -r romdump/{README,ROMDump*}
46 }
47
48 pkg_postinst() {
49         elog "The X48 emulator requires an HP48 ROM image to run."
50         elog
51         elog "If you own an HP-48 calculator, you can use the ROMDump utility"
52         elog "included with this package to obtain it from your calculator."
53         elog "The instructions of how to do this are included in the package."
54         elog
55         elog "Alternatively, HP has provided the ROM images for non-commercial"
56         elog "use only."
57         elog
58         elog "Due to confusion over the legal status of these ROMs you must"
59         elog "manually download one from http://www.hpcalc.org/hp48/pc/emulators/"
60         elog
61         elog "If you do not know which one to use, try 'HP 48GX Revision R ROM.'"
62         elog
63         elog "Once you have a ROM, you will need to install it by running:"
64         elog
65         elog "x48 -rom gxrom-r"
66         elog
67         elog "You will only have to do this the first time you run X48. The"
68         elog "ROM will be stored in ~/.hp48/rom for future runs."
69 }