adf1fb7481d8aa0b1570f16e1f9f6235a5d7f7a1
[gentoo.git] / app-emulation / vkd3d / vkd3d-1.1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit multilib-minimal
7
8 if [[ "${PV}" == "9999" ]]; then
9         EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
10         inherit git-r3
11 else
12         KEYWORDS="~amd64"
13         SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
14 fi
15
16 IUSE="spirv-tools"
17 RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
18                 media-libs/vulkan-loader[${MULTILIB_USEDEP},X]
19                 x11-libs/xcb-util:=[${MULTILIB_USEDEP}]
20                 x11-libs/xcb-util-keysyms:=[${MULTILIB_USEDEP}]
21                 x11-libs/xcb-util-wm:=[${MULTILIB_USEDEP}]"
22
23 DEPEND="${RDEPEND}
24                 dev-util/spirv-headers
25                 dev-util/vulkan-headers"
26
27 DESCRIPTION="D3D12 to Vulkan translation library"
28 HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
29
30 LICENSE="LGPL-2.1"
31 SLOT="0"
32
33 multilib_src_configure() {
34         local myconf=(
35                 $(use_with spirv-tools)
36         )
37
38         ECONF_SOURCE=${S} econf "${myconf[@]}"
39 }