app-emulation/ganeti: add patches to fix building manpages/newer pyopenssl
[gentoo.git] / app-emulation / qemu-init-scripts / qemu-init-scripts-0.3.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Kvm and qemu init scripts"
7 HOMEPAGE="https://gitweb.gentoo.org/proj/kvm-tools.git/"
8
9 SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.xz"
10 LICENSE="GPL-2"
11 SLOT=0
12 KEYWORDS="~amd64 ~x86"
13
14 RDEPEND="
15         app-emulation/qemu
16         net-misc/socat"
17
18 S="${PORTAGE_BUILDDIR}/work/${PN}"
19
20 src_prepare() {
21         epatch_user
22 }
23
24 src_install() {
25         newinitd "${S}/"qemu-init-script qemu
26         newconfd "${S}/"qemu-conf.example qemu.conf.example
27         newsbin "${S}/"qtap-manipulate qtap-manipulate
28         dosym qemu /etc/init.d/kvm
29 }
30
31 pkg_postinst() {
32         elog "For bridging networking systems, you need these run time utilities:"
33         elog "    net-misc/bridge-utils"
34         elog "    sys-apps/usermode-utilities"
35         elog ""
36         elog "We will be updating these scripts to use"
37         elog "iptables exclusively in the future"
38 }