dev-qt/qthelp: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-emulation / qemu-init-scripts / qemu-init-scripts-0.3.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Kvm and qemu init scripts"
7 HOMEPAGE="https://gitweb.gentoo.org/proj/kvm-tools.git/"
8
9 SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.xz"
10 LICENSE="GPL-2"
11 SLOT=0
12 KEYWORDS="~amd64 ~x86"
13
14 RDEPEND="
15         app-emulation/qemu
16         net-misc/socat"
17
18 S="${WORKDIR}/${PN}"
19 PATCHES=( "${FILESDIR}"/openrc-run.patch )
20
21 src_install() {
22         newinitd "${S}/"qemu-init-script qemu
23         newconfd "${S}/"qemu-conf.example qemu.conf.example
24         newsbin "${S}/"qtap-manipulate qtap-manipulate
25         dosym qemu /etc/init.d/kvm
26 }
27
28 pkg_postinst() {
29         elog "For bridging networking systems, you need these run time utilities:"
30         elog "    net-misc/bridge-utils"
31         elog "    sys-apps/usermode-utilities"
32         elog ""
33         elog "We will be updating these scripts to use"
34         elog "iptables exclusively in the future"
35 }