dev-python/lxml: Version bump to 3.6.4
[gentoo.git] / app-emulation / hercules / hercules-3.10.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 inherit flag-o-matic eutils
8
9 DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
10 HOMEPAGE="http://www.hercules-390.eu/"
11 SRC_URI="http://downloads.hercules-390.eu/${P}.tar.gz"
12
13 LICENSE="QPL-1.0"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x64-macos ~x86-macos"
16 IUSE="bzip2 custom-cflags +suid"
17
18 RDEPEND="bzip2? ( app-arch/bzip2 )
19         sys-libs/zlib"
20 DEPEND="${RDEPEND}"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${PN}-3.09-aliasing.patch
24 }
25
26 src_configure() {
27         use custom-cflags || strip-flags
28         ac_cv_lib_bz2_BZ2_bzBuffToBuffDecompress=$(usex bzip2) \
29         econf \
30                 $(use_enable bzip2 cckd-bzip2) \
31                 $(use_enable bzip2 het-bzip2) \
32                 $(use_enable suid setuid-hercifc) \
33                 --enable-custom="Gentoo ${PF}.ebuild" \
34                 --disable-optimization
35 }
36
37 src_install() {
38         default
39         insinto /usr/share/hercules
40         doins hercules.cnf
41         dodoc README.* RELEASE.NOTES
42         dohtml -r html
43 }