dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / app-emulation / go-secbench / go-secbench-0.1.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 EGO_PN="github.com/qnib/go-secbench"
6 inherit golang-build golang-vcs-snapshot
7
8 DESCRIPTION="run and evaluate the docker security benchmark"
9 HOMEPAGE="https://github.com/qnib/go-secbench"
10 SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 RESTRICT="test"
16
17 DEPEND="dev-lang/go"
18
19 src_compile() {
20         GOPATH="${S}" go build -o bin/go-secbench src/${EGO_PN}/cmd/main.go || die
21 }
22
23 src_install() {
24         dobin bin/${PN}
25 dodoc "src/${EGO_PN}/README.md"
26 }