Merge remote-tracking branch 'github/pr/708'.
[gentoo.git] / app-emulation / ganeti-instance-debootstrap / ganeti-instance-debootstrap-0.9.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=2
6
7 inherit eutils
8
9 DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
10 HOMEPAGE="http://www.ganeti.org/"
11 SRC_URI="https://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND="app-arch/dpkg
20         app-arch/dump
21         app-emulation/ganeti
22         dev-util/debootstrap
23         >=sys-apps/coreutils-6.10-r1
24         sys-apps/util-linux
25         sys-fs/e2fsprogs"
26
27 src_configure() {
28         econf --docdir=/usr/share/doc/${P} || die "econf failed"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die "install failed"
33         insinto /etc/ganeti/instance-debootstrap/hooks
34         doins examples/hooks/*
35 }