www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / app-emulation / fuse-utils / fuse-utils-1.4.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Utils for the Free Unix Spectrum Emulator by Philip Kendall"
7 HOMEPAGE="http://fuse-emulator.sourceforge.net"
8 SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="audiofile gcrypt jpeg png zlib"
14
15 RDEPEND=">=app-emulation/libspectrum-1.4.4[gcrypt?,zlib?]
16         audiofile? ( >=media-libs/audiofile-0.3.6 )
17         jpeg? ( virtual/jpeg:0 )
18         png? ( media-libs/libpng:0 )
19         zlib? ( sys-libs/zlib )"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig"
22
23 src_configure() {
24         local myconf=(
25                 $(use_with audiofile)
26                 $(use_with gcrypt libgcrypt)
27                 $(use_with jpeg libjpeg)
28                 $(use_with png libpng)
29                 $(use_with zlib)
30         )
31         econf "${myconf[@]}"
32 }