sys-libs/readline: stable 8.0_p4 for hppa, bug #719942
[gentoo.git] / app-emulation / free42 / free42-2.5.18.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 MY_PV="${PN}-nologo-${PV}"
9
10 DESCRIPTION="An HP-42S Calculator Simulator"
11 HOMEPAGE="https://thomasokken.com/free42/"
12 SRC_URI="https://thomasokken.com/free42/upstream/${MY_PV}.tgz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="+alsa"
18
19 DEPEND="dev-libs/atk
20         x11-libs/cairo
21         x11-libs/gdk-pixbuf
22         x11-libs/gtk+:3
23         alsa? ( media-libs/alsa-lib )"
24
25 RDEPEND="${DEPEND}"
26
27 DOCS=( CREDITS HISTORY README )
28 S="${WORKDIR}/${MY_PV}"
29
30 PATCHES=(
31         "${FILESDIR}/${PN}-2.5.16-fix-makefile.patch"
32         "${FILESDIR}/${PN}-2.5.3-fix-build-intel-lib.patch"
33 )
34
35 src_prepare() {
36         default
37 }
38
39 src_compile() {
40         local myconf
41         use alsa && myconf="AUDIO_ALSA=yes"
42         emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" ${myconf} -C gtk
43         emake -C gtk clean
44         emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C gtk
45 }
46
47 src_install() {
48         default
49         dobin gtk/free42bin gtk/free42dec
50 }