dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / app-emulation / free42 / free42-2.0.20.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit eutils toolchain-funcs
7
8 MY_PV="${PN}-nologo-${PV}"
9
10 DESCRIPTION="An HP-42S Calculator Simulator"
11 HOMEPAGE="https://thomasokken.com/free42/"
12 SRC_URI="https://thomasokken.com/free42/upstream/${MY_PV}.tgz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="alsa"
18
19 DEPEND="dev-libs/atk
20         x11-libs/cairo
21         x11-libs/gdk-pixbuf
22         x11-libs/gtk+:2
23         x11-libs/pango
24         alsa? ( media-libs/alsa-lib )"
25
26 RDEPEND="${DEPEND}
27         x11-libs/libX11
28         x11-libs/libXmu"
29
30 S="${WORKDIR}/${MY_PV}"
31
32 PATCHES=(
33         "${FILESDIR}/${PN}-2.0.10-fix-makefile.patch"
34         "${FILESDIR}/${PN}-2.0.10-fix-build-intel-lib.patch"
35 )
36
37 src_prepare() {
38         default
39 }
40
41 src_compile() {
42         local myconf
43         use alsa && myconf="AUDIO_ALSA=yes"
44         emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C "${S}/gtk"
45 }
46
47 src_install() {
48         dodoc CREDITS HISTORY README
49         dobin gtk/free42dec
50 }