media-plugins/gst-plugins-wavpack-1.10.3-r0: add alpha keyword
[gentoo.git] / app-emulation / diskimage-builder / diskimage-builder-2.2.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Golden Disk Image builder."
10 HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
16 IUSE=""
17
18 CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
19 DEPEND="${CDEPEND}
20         dev-python/setuptools[${PYTHON_USEDEP}]"
21 RDEPEND="${CDEPEND}
22         >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
23         >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
24         >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
25         <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
26         >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
27         app-emulation/qemu
28         sys-block/parted
29         sys-fs/multipath-tools
30         !dev-python/dib-utils[${PYTHON_USEDEP}]"