dev-python/boto3: 9999: update copyright line
[gentoo.git] / app-emulation / containerd / containerd-9999.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 EGO_PN="github.com/containerd/${PN}"
6
7 inherit toolchain-funcs
8
9 if [[ ${PV} == *9999 ]]; then
10         inherit golang-vcs
11 else
12         MY_PV="${PV/_beta/-beta.}"
13         EGIT_COMMIT="v${MY_PV}"
14         SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64 ~arm ~ppc64"
16         inherit golang-vcs-snapshot
17 fi
18
19 DESCRIPTION="A daemon to control runC"
20 HOMEPAGE="https://containerd.tools"
21
22 LICENSE="Apache-2.0"
23 SLOT="0"
24 IUSE="hardened +seccomp"
25
26 DEPEND=""
27 RDEPEND=">=app-emulation/runc-1.0.0_rc4
28         seccomp? ( sys-libs/libseccomp )"
29
30 S=${WORKDIR}/${P}/src/${EGO_PN}
31
32 src_compile() {
33         local options=( $(usex seccomp "seccomp" "") )
34         export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
35         LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
36 }
37
38 src_install() {
39         dobin bin/containerd{-shim,-stress,} bin/ctr
40 }