Convert URIs for googlecode.com to https
[gentoo.git] / app-emacs / yasnippet / yasnippet-0.6.0c.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit elisp
6
7 DESCRIPTION="Yet another snippet extension for Emacs"
8 HOMEPAGE="https://code.google.com/p/yasnippet/"
9 SRC_URI="https://yasnippet.googlecode.com/files/${P}.tar.bz2
10         doc? ( https://yasnippet.googlecode.com/files/${PN}-doc-${PV}.tar.bz2 )"
11
12 # Homepage says MIT licence, source contains GPL-2 copyright notice
13 LICENSE="MIT GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17
18 DEPEND=">=app-emacs/dropdown-list-20080316"
19 RDEPEND="${DEPEND}"
20
21 SITEFILE="50${PN}-gentoo.el"
22
23 src_unpack() {
24         elisp_src_unpack
25
26         # remove bundled copy of dropdown-list
27         rm "${S}/dropdown-list.el" || die
28 }
29
30 src_install() {
31         elisp_src_install
32
33         insinto "${SITEETC}/${PN}"
34         doins -r snippets || die "doins failed"
35
36         if use doc; then
37                 dohtml -r "${WORKDIR}"/doc/* || die "dohtml failed"
38         fi
39 }
40
41 pkg_postinst() {
42         elisp-site-regen
43
44         elog "Please add the following code into your .emacs to use yasnippet:"
45         elog "(yas/initialize)"
46         elog "(yas/load-directory \"${SITEETC}/${PN}/snippets\")"
47 }