app-emacs/lyskom-elisp-client: x86 stable wrt bug #715296
[gentoo.git] / app-emacs / websocket / websocket-1.10.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 NEED_EMACS=24
6
7 inherit elisp
8
9 DESCRIPTION="A websocket implementation in elisp"
10 HOMEPAGE="https://github.com/ahyatt/emacs-websocket"
11 SRC_URI="https://github.com/ahyatt/emacs-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 S="${WORKDIR}/emacs-${P}"
18 SITEFILE="50${PN}-gentoo.el"
19
20 src_compile() {
21         elisp-compile websocket.el
22 }
23
24 src_test() {
25         ${EMACS} ${EMACSFLAGS} -L . -l websocket-test \
26                 -f ert-run-tests-batch-and-exit
27 }
28
29 src_install() {
30         elisp-install ${PN} websocket.{el,elc}
31         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
32         dodoc README.org websocket-functional-test.el testserver.py
33 }