Revert "app-emacs/vm: Depend on <app-emacs/bbdb-3."
[gentoo.git] / app-emacs / vm / vm-8.1.2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit elisp eutils
7
8 MY_PV="${PV/_/-}"
9 MY_P="${PN}-${MY_PV}"
10 DESCRIPTION="The VM mail reader for Emacs"
11 HOMEPAGE="http://www.nongnu.org/viewmail/"
12 SRC_URI="https://launchpad.net/vm/${PV%.*}.x/${MY_PV}/+download/${MY_P}.tgz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86"
17 IUSE="bbdb ssl"
18
19 DEPEND="bbdb? ( app-emacs/bbdb )"
20 RDEPEND="!app-emacs/u-vm-color
21         ${DEPEND}
22         ssl? ( net-misc/stunnel )"
23
24 S="${WORKDIR}/${MY_P}"
25 SITEFILE="50${PN}-gentoo-8.0.el"
26
27 src_prepare() {
28         if ! use bbdb; then
29                 elog "Excluding vm-pcrisis.el since the \"bbdb\" USE flag is not set."
30                 epatch "${FILESDIR}/${PN}-8.0-no-pcrisis.patch"
31         fi
32         epatch "${FILESDIR}/${P}-texinfo-5.patch"
33 }
34
35 src_configure() {
36         econf \
37                 --with-emacs="emacs" \
38                 --with-pixmapdir="${SITEETC}/${PN}" \
39                 $(use bbdb && echo "--with-other-dirs=${SITELISP}/bbdb")
40 }
41
42 src_compile() {
43         emake -j1
44 }
45
46 src_install() {
47         emake -j1 DESTDIR="${D}" install
48         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
49         dodoc CHANGES NEWS README TODO example.vm
50 }