app-emacs/eselect-mode: x86 stable wrt bug #715300
[gentoo.git] / app-emacs / template / template-3.3b.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="Use templates, decorate comments, auto-update buffers"
9 HOMEPAGE="http://emacs-template.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/emacs-template/${P}.tar.gz"
11
12 LICENSE="GPL-2+ Texinfo-manual"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 S="${WORKDIR}"
17 SITEFILE="50${PN}-gentoo.el"
18
19 src_install() {
20         elisp-install ${PN} *.{el,elc}
21         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
22
23         insinto "${SITEETC}/${PN}"
24         doins -r templates
25         doinfo template.info
26 }