Use https by default
[gentoo.git] / app-emacs / rudel / rudel-0.3_pre20110721.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit readme.gentoo elisp
8
9 DESCRIPTION="Collaborative editing environment for GNU Emacs"
10 HOMEPAGE="http://rudel.sourceforge.net/
11         http://www.emacswiki.org/emacs/Rudel"
12 # snapshot of bzr://rudel.bzr.sourceforge.net/bzrroot/rudel/trunk
13 SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
14
15 LICENSE="GPL-3+"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18
19 S="${WORKDIR}/${PN}"
20 SITEFILE="60${PN}-gentoo.el"
21
22 src_compile() {
23         ${EMACS} ${EMACSFLAGS} -l rudel-compile.el || die
24 }
25
26 src_install() {
27         local dir
28
29         for dir in . adopted infinote jupiter obby socket telepathy tls \
30                 xmpp zeroconf
31         do
32                 insinto "${SITELISP}/${PN}/${dir}"
33                 doins ${dir}/*.{el,elc}
34         done
35
36         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
37
38         insinto "${SITEETC}/${PN}"
39         doins -r icons
40
41         dodoc README INSTALL ChangeLog TODO doc/card.pdf
42
43         DOC_CONTENTS="Connections to Gobby servers require the gnutls-cli program
44                 (net-libs/gnutls).
45                 \\n\\nThe Avahi daemon (net-dns/avahi) is required for automatic
46                 session discovery and advertising."
47         readme.gentoo_create_doc
48 }