app-emacs/eselect-mode: ppc stable wrt bug #715300
[gentoo.git] / app-emacs / puppet-mode / puppet-mode-0.3.20180813.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit elisp
7
8 COMMIT=7dee1b5a5debac6e56f9107492a413b6c0edb94d
9
10 DESCRIPTION="Emacs major mode for editing Puppet manifests"
11 HOMEPAGE="https://github.com/voxpupuli/puppet-mode"
12 SRC_URI="https://github.com/voxpupuli/puppet-mode/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
13 S="${WORKDIR}/${PN}-${COMMIT}"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
18
19 DOCS="CHANGES.md README.md"
20 SITEFILE="50${PN}-1-gentoo.el"
21
22 # Tests require unpackaged ert-runner
23 RESTRICT="test"
24
25 src_prepare() {
26         elisp_src_prepare
27
28         sed -i -e 's/@VERSION@/'${PV}'/' puppet-mode.el || die
29 }