sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / app-emacs / psgml / psgml-1.4.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="A GNU Emacs Major Mode for editing SGML and XML coded documents"
9 HOMEPAGE="https://www.emacswiki.org/emacs/PsgmlMode"
10 # taken from https://marmalade-repo.org/packages/${P}.tar
11 SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
12
13 LICENSE="GPL-2+ Texinfo-manual"
14 SLOT="0"
15 KEYWORDS="amd64 ppc x86"
16
17 RDEPEND="app-text/openjade"
18
19 SITEFILE="50${PN}-gentoo.el"
20
21 src_compile() {
22         ${EMACS} ${EMACSFLAGS} --load psgml-maint.el -f psgml-compile-files || die
23 }
24
25 src_install() {
26         elisp-install ${PN} *.el *.elc
27         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
28         insinto "${SITEETC}/${PN}"
29         doins *.map
30         doinfo psgml.info psgml-api.info
31         dodoc ChangeLog INSTALL README.psgml psgml.ps
32 }