app-emacs/pymacs: Remove old.
[gentoo.git] / app-emacs / pariemacs / pariemacs-3.14.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit elisp
7
8 DESCRIPTION="sci-mathematics/pari emacs mode"
9 HOMEPAGE="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14 SRC_URI="http://iml.univ-mrs.fr/~ramare/ServeurPerso/GP-PARI/latest-pari-distrib/${P}.tar.gz"
15
16 RDEPEND="sci-mathematics/pari"
17 DEPEND="${RDEPEND}"
18
19 S="${WORKDIR}"
20 SITEFILE="64${PN}-gentoo.el"
21 DOCS="README CHANGES"
22
23 src_prepare() {
24         eapply "${FILESDIR}"/${P}-makefile.patch
25         eapply_user
26         if [ -f /usr/share/doc/pari-*/pari.cfg ]; then
27                 cp /usr/share/doc/pari-*/pari.cfg .
28         elif [ -f /usr/share/doc/pari-*/pari.cfg.bz2 ]; then
29                 cp /usr/share/doc/pari-*/pari.cfg.bz2 .
30                 bunzip2 pari.cfg.bz2
31         else die "pari.cfg not found"
32         fi
33 }
34
35 src_compile() {
36         make pari-conf.el
37         make elc
38 }