app-emacs/ebuild-mode: Remove old.
[gentoo.git] / app-emacs / nxml-docbook5-schemas / nxml-docbook5-schemas-5.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="Add support for DocBook 5 schemas to NXML"
9 HOMEPAGE="https://docbook.org/schemas/5x.html"
10 SRC_URI="https://docbook.org/xml/${PV}/rng/docbookxi.rnc -> docbookxi-${PV}.rnc"
11
12 LICENSE="HPND"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15
16 S="${WORKDIR}"
17 SITEFILE="60${PN}-gentoo.el"
18
19 src_unpack() { :; }
20
21 src_compile() { :; }
22
23 src_install() {
24         insinto ${SITEETC}/${PN}
25         doins "${FILESDIR}"/schemas.xml
26         newins "${DISTDIR}"/docbookxi-${PV}.rnc docbookxi.rnc
27         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
28 }