Merge remote-tracking branch 'RobinDX/qbit'
[gentoo.git] / app-emacs / navi2ch / navi2ch-1.8.3-r1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=3
6
7 inherit elisp
8
9 DESCRIPTION="A navigator for the Japanese textboard 2ch"
10 HOMEPAGE="http://navi2ch.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/navi2ch/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
16 IUSE=""
17
18 SITEFILE="50${PN}-gentoo.el"
19
20 src_configure() {
21         econf \
22                 --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
23                 --with-icondir="${EPREFIX}${SITEETC}/${PN}"
24 }
25
26 # This is NOT redundant, elisp.eclass redefines src_compile
27 src_compile() {
28         emake || die "emake failed"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die "emake install failed"
33         elisp-install ${PN} contrib/*.el || die
34         elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
35         dodoc ChangeLog* NEWS README TODO || die
36         newdoc contrib/README README.contrib || die
37 }
38
39 pkg_postinst() {
40         elisp-site-regen
41         elog
42         elog "Please add to your ~/.emacs"
43         elog "If you use mona-font,"
44         elog "\t(setq navi2ch-mona-enable t)"
45         elog "If you use izonmoji-mode,"
46         elog "\t(require 'izonmoji-mode)"
47         elog "\t(add-hook 'navi2ch-bm-mode-hook   'izonmoji-mode-on)"
48         elog "\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)"
49         elog "\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
50         elog
51 }