*/*: Drop stable ia64 keywords
[gentoo.git] / app-emacs / mpg123-el / mpg123-el-1.60.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit elisp toolchain-funcs
7
8 DESCRIPTION="Emacs front-end to mpg123 audio player and OggVorbis audio player"
9 HOMEPAGE="http://www.gentei.org/~yuuji/software/mpg123el/"
10 SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
11
12 LICENSE="mpg123-el"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86"
15
16 RDEPEND="media-sound/mpg123
17         media-sound/alsa-utils"
18
19 SITEFILE="50${PN}-gentoo.el"
20
21 src_compile() {
22         $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o tagput tagput.c || die
23         $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o id3put id3put.c || die
24         elisp-compile *.el
25 }
26
27 src_install() {
28         dobin tagput id3put
29         elisp-install ${PN} *.el *.elc
30         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
31 }