app-emacs/pymacs: x86 stable wrt bug #721740
[gentoo.git] / app-emacs / mldonkey / mldonkey-0.0.4b-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp readme.gentoo-r1
7
8 MY_P="${PN}-el-${PV}"
9 DESCRIPTION="An Emacs Lisp interface to the MLDonkey core"
10 HOMEPAGE="https://www.emacswiki.org/emacs/MlDonkey
11         http://web.archive.org/web/20070107165326/www.physik.fu-berlin.de/~dhansen/mldonkey/"
12 SRC_URI="http://www.physik.fu-berlin.de/%7Edhansen/mldonkey/files/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86"
17
18 S="${WORKDIR}/${MY_P}"
19 ELISP_PATCHES="${P}-vd.patch ${P}-emacs-26.patch"
20 SITEFILE="50${PN}-gentoo.el"
21 DOC_CONTENTS="If your network gets really slow when you use mldonkey,
22         consider reducing the max number of connections. See bug #50510.
23         \n\nRemember to install net-p2p/mldonkey separately if you want to
24         work with a local instance."
25
26 src_compile() {
27         elisp-compile ml*.el
28 }