app-emacs/csv-mode: amd64/sparc/x86 stable, (ALLARCHES policy) wrt bug #705558
[gentoo.git] / app-emacs / lookup / lookup-1.99.96_pre20180209.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools elisp
7
8 COMMIT="c4f4986aac6c339e03b9e56a5dfc7c8f5c0bb5e0"
9 DESCRIPTION="An interface to search CD-ROM books and network dictionaries"
10 HOMEPAGE="https://lookup2.github.io/lookup2/"
11 SRC_URI="https://github.com/lookup2/lookup2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16
17 BDEPEND="sys-apps/texinfo"
18
19 S="${WORKDIR}/lookup2-${COMMIT}"
20 SITEFILE="50${PN}-gentoo.el"
21
22 src_prepare() {
23         default
24         eautoreconf
25 }
26
27 src_configure() {
28         econf --with-lispdir="${EPREFIX}${SITELISP}"
29 }
30
31 src_compile() {
32         default
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install
37         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
38         dodoc AUTHORS NEWS README.md
39 }