app-emacs/nxml-gentoo-schemas: ppc64 stable wrt bug #717324
[gentoo.git] / app-emacs / howm / howm-1.4.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit elisp
7
8 DESCRIPTION="Note-taking tool on Emacs"
9 HOMEPAGE="https://howm.sourceforge.jp/"
10 SRC_URI="http://howm.sourceforge.jp/a/${P}.tar.gz"
11
12 LICENSE="GPL-1+ GPL-2+"
13 SLOT="0"
14 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
15
16 SITEFILE="50${PN}-gentoo.el"
17
18 src_configure() {
19         default
20 }
21
22 src_compile() {
23         emake -j1 </dev/null
24 }
25
26 src_install() {
27         emake -j1 DESTDIR="${D}" install </dev/null
28         elisp-site-file-install "${FILESDIR}/${SITEFILE}"
29         dodoc ChangeLog
30 }