app-emacs/nxml-gentoo-schemas: x86 stable wrt bug #717324
[gentoo.git] / app-emacs / highline / highline-7.2.2.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit elisp
7
8 DESCRIPTION="Minor mode to highlight current line in buffer"
9 HOMEPAGE="https://www.emacswiki.org/emacs/HighlineMode"
10 # taken from: http://www.emacswiki.org/emacs/download/${PN}.el
11 SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
12
13 LICENSE="GPL-3+"
14 SLOT="0"
15 KEYWORDS="amd64 ppc ~s390 ~sparc x86"
16
17 SITEFILE="50${PN}-gentoo.el"
18
19 src_compile() {
20         elisp-compile *.el
21         elisp-make-autoload-file
22 }