app-emacs/pymacs: Remove py2
[gentoo.git] / app-emacs / graphql / graphql-0.1.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 NEED_EMACS=25
6
7 inherit elisp
8
9 DESCRIPTION="GraphQL utilities"
10 HOMEPAGE="https://github.com/vermiculus/graphql.el"
11 SRC_URI="https://github.com/vermiculus/graphql.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
12 S="${WORKDIR}/${PN}.el-${PV}"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17
18 SITEFILE="50${PN}-gentoo.el"
19 DOCS="README.md"
20
21 # Tries to download emake tool on the fly
22 RESTRICT="test"
23
24 src_prepare() {
25         # Avoid examples which would require circular dependencies
26         rm -f examples.el || die
27
28         default
29 }